Savage 2 error updating

Posted by / 26-Aug-2017 20:22

Savage 2 error updating

Though after installing the patched version I get a 'no screens found' notification when trying to start the X server.

This shows up in the related log[ 3407.130] (EE) module ABI major version (20) doesn't match the server's version (12) [ 3407.130] (II) Unload Module: "savage" [ 3407.130] (II) Unloading savage [ 3407.130] (EE) Failed to load module "savage" (module requirement mismatch, 0) [ 3407.130] (EE) No drivers available.

After updating the file as shown in the wiki I get an error though:wrap.

Post Validate Tree = NULL; ^ Makefile:419: recipe for target 'savage_dri.lo' failed make[2]: *** [savage_dri.lo] Error 1 make[2]: Leaving directory '/home/optimus/Packages/xf86-video-savage/repos/extra-i686/src/xf86-video-savage-2.3.6/src' Makefile:353: recipe for target 'all-recursive' failed make[1]: *** [all-recursive] Error 1 make[1]: Leaving directory '/home/optimus/Packages/xf86-video-savage/repos/extra-i686/src/xf86-video-savage-2.3.6' Makefile:284: recipe for target 'all' failed make: *** [all] Error 2 == pkgname=xf86-video-savage pkgver=2.3.6 pkgrel=1 pkgdesc="savage video driver" arch=(i686 x86_64) url=" license=('custom') depends=('glibc') makedepends=('xorg-server-devel pkgname=xf86-video-savage pkgver=2.3.6 pkgrel=1 pkgdesc="savage video driver" arch=(i686 x86_64) url=" license=('custom') depends=('glibc') makedepends=('xorg-server-devel Are there additional steps needed as of today in order to build an older package?

Also, you should be using the prepare function for patching... That is, if one lacks any previous packages, or backups of these, the XAA acceleration can not be used in a T23 setup by building the related packages.

@pypi If it is broken, should I understand that the whole building process, of which the xorg server package is a central part, as explained in the wiki link is (as of now? Regarding the xf86-video-savage package it is the original one.

Sorry - I probably wasn't very clear - the patch I linked to in the prior post should fix the xorg-server build error.

), the longest stay atop the chart for a rap song this year.

Plus, Camila Cabello's "Havana," featuring Young Thug, soars from No. 2 on the Hot 100, marking a new career best (counting both her solo songs and those with her former group, Fifth Harmony).

The error noted in the same message is what puzzles me.

Is it mandatory to built the savage driver against the new build xorg-server or would it be enough to use the already existing savage package version 'older than What I am imagining needs to happen:- Rebuild xorg-server (version 1.12).

savage 2 error updating-68savage 2 error updating-18savage 2 error updating-87

EDIT: Since the packages are quite old, you will have to (or at least, it would be a good idea to) rebuild them - otherwise you will have problems with missing/outdated libraries (libgcrypt, for instance...).

One thought on “savage 2 error updating”